RIP, EIGRP, OSPF, IS-IS, BGP, MPLS, VTP, STP.
User avatar
Pasu
New Member
Posts:
23
Joined:
Sun Apr 28, 2013 11:39 pm

cisco switch 2960

Sun Apr 28, 2013 11:50 pm

Hi everyone,
I am new member to this forum. I am sorry if i have post this in wrong place.
I have problem in configuring cisco switch. Actually everything is done. I can even login the switch through telnet and ssh but the problem is in my switch the username in 'test' and password is also 'test' but when i login any username can login with the password 'test' but username 'test' cannot login with the same password. :shock:

I dont have any idea about this.
Any help will be appreciated.
"Lay a firm Foundation with the bricks that others throw at you" ~David Brinkley

killabee
Post Whore
Posts:
1441
Joined:
Sat Dec 19, 2009 11:52 pm
Certs:
CCNP, CCDA, JNCIA

Re: cisco switch 2960

Mon Apr 29, 2013 12:12 am

How are you logging in? Through the console or through SSH/telnet? What error are you getting?

Sounds like all the other usernames correctly have the password set to "test," whereas the username "test" doesn't have the password correctly set.

Try deleting the username "test" and re-adding it.

If that doesn't work, post the running config.

User avatar
Pasu
New Member
Posts:
23
Joined:
Sun Apr 28, 2013 11:39 pm

Re: cisco switch 2960

Mon Apr 29, 2013 12:25 am

I can login through console, telnet and ssh. I am not getting any error.
i can type anything in username even which are not there in list but password should be correct. I have only one username that is 'test' and with that its not working.

here is the running config

Code: Select all
version 12.2
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname Pasang
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$dMGv$oaETUwS45CooMDQ9CFTU51
!
username test
!
!
aaa new-model
!
!
aaa authentication login default local enable
aaa authentication enable default enable
!
!
!
aaa session-id common
clock timezone bst 6
switch 1 provision ws-c2960s-48fps-l
!
!
no ip domain-lookup
ip domain-name tashicell.com
!
!
crypto pki trustpoint TP-self-signed-3645381376
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3645381376
 revocation-check none
 rsakeypair TP-self-signed-3645381376
!
!
crypto pki certificate chain TP-self-signed-3645381376
 certificate self-signed 01
  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33363435 33383133 3736301E 170D3933 30333031 30303036
  30325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36343533
  38313337 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E0BA 4421DC47 FCF72FBB 4692271E 6F798F28 E37DD1B9 48466E2F 2E339713
  2210583D 029AB1C3 8A0382BE 422A47E7 A48A9CF8 E42BBDD6 0838B54B F7BD91A9
  2B6BBA58 3D09046E 4E68125D 75CCA412 4B3AD7E2 553CF903 6FD9DC57 A7760E48
  9C7F935B 85DAC8AC 838654EC ECF5B892 30E1BB32 97B7F165 8720BD29 08D3486A
  02630203 010001A3 74307230 0F060355 1D130101 FF040530 030101FF 301F0603
  551D1104 18301682 14506173 616E672E 74617368 6963656C 6C2E636F 6D301F06
  03551D23 04183016 801478D0 8793C792 A0B77F7E FDD0BCE3 FB2887FB EB20301D
  0603551D 0E041604 1478D087 93C792A0 B77F7EFD D0BCE3FB 2887FBEB 20300D06
  092A8648 86F70D01 01040500 03818100 05F819FF C330867B E5C6F3E3 1315D625
  59B8FD51 3A25EA46 06E371EA B36025C0 EA44307E C35B3AF2 6F310BBB CADA031D
  795FEC62 9BEC6F70 20B1168B 35FEC33C A01BF8E3 45BE6D16 DDE60E42 BCE49CAD
  8E2C9F62 850724E6 99366A55 5F95E185 933E85DE 68C24F49 AF81BF40 62B05D5A
  99566685 F5203EB2 BD802127 E7305D26
  quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
 switchport access vlan 10
!
interface GigabitEthernet1/0/2
 switchport access vlan 10
!
interface GigabitEthernet1/0/3
 switchport access vlan 10
!
interface GigabitEthernet1/0/4
 switchport access vlan 10
!
interface GigabitEthernet1/0/5
 switchport access vlan 10
!
interface GigabitEthernet1/0/6
 switchport access vlan 10
!
interface GigabitEthernet1/0/7
 switchport access vlan 10
!
interface GigabitEthernet1/0/8
 switchport access vlan 10
!
interface GigabitEthernet1/0/9
 switchport access vlan 10
!
interface GigabitEthernet1/0/10
 switchport access vlan 10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
 switchport access vlan 10
!
interface GigabitEthernet1/0/13
 switchport access vlan 20
!
interface GigabitEthernet1/0/14
 switchport access vlan 20
!
interface GigabitEthernet1/0/15
 switchport access vlan 20
!
interface GigabitEthernet1/0/16
 switchport access vlan 20
!
interface GigabitEthernet1/0/17
 switchport access vlan 20
!
interface GigabitEthernet1/0/18
 switchport access vlan 20
!
interface GigabitEthernet1/0/19
 switchport access vlan 20
!
interface GigabitEthernet1/0/20
 switchport access vlan 20
!
interface GigabitEthernet1/0/21
 switchport access vlan 20
!
interface GigabitEthernet1/0/22
 switchport access vlan 20
!
interface GigabitEthernet1/0/23
 switchport access vlan 20
!
interface GigabitEthernet1/0/24
 switchport access vlan 20
!
interface GigabitEthernet1/0/25
 switchport access vlan 30
!
interface GigabitEthernet1/0/26
 switchport access vlan 30
!
interface GigabitEthernet1/0/27
 switchport access vlan 30
!
interface GigabitEthernet1/0/28
 switchport access vlan 30
!
interface GigabitEthernet1/0/29
 switchport access vlan 30
!
interface GigabitEthernet1/0/30
 switchport access vlan 30
!
interface GigabitEthernet1/0/31
 switchport access vlan 30
!
interface GigabitEthernet1/0/32
 switchport access vlan 30
!
interface GigabitEthernet1/0/33
 switchport access vlan 30
!
interface GigabitEthernet1/0/34
 switchport access vlan 30
!
interface GigabitEthernet1/0/35
 switchport access vlan 30
!
interface GigabitEthernet1/0/36
 switchport access vlan 30
!
interface GigabitEthernet1/0/37
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
!
interface GigabitEthernet1/0/48
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 description Management Vlan Interface
 ip address 192.168.1.50 255.255.255.0
!
no ip http server
no ip http secure-server
ip sla enable reaction-alerts
banner login ^C
########################################################
                 This is ISP Switch
            Unauthorised access is prohibiteed.
########################################################
^C
!
line con 0
line vty 0 4
 transport preferred none
 transport input telnet ssh
 transport output none
line vty 5 15
!
end
"Lay a firm Foundation with the bricks that others throw at you" ~David Brinkley

User avatar
mynd
Ultimate Member
Posts:
883
Joined:
Fri Jul 23, 2010 9:43 am
Certs:
CCNA, A+, Net+, Sec+, Server+

Re: cisco switch 2960

Mon Apr 29, 2013 12:29 am

doesn't look like you have a password associated with the username.

Try:

username test password test


Sent using Tapatalk
http://justnetworked.wordpress.com

User avatar
Pasu
New Member
Posts:
23
Joined:
Sun Apr 28, 2013 11:39 pm

Re: cisco switch 2960

Mon Apr 29, 2013 1:06 am

i did that.
"username test and password test".
but seems the username test is of no use because it wont work when i try to login with this username.
"Lay a firm Foundation with the bricks that others throw at you" ~David Brinkley

bertschs
Senior Member
Posts:
311
Joined:
Sun Apr 17, 2011 7:06 pm

Re: cisco switch 2960

Mon Apr 29, 2013 1:43 am

You have "aaa authentication login default local enable" set.

You also have the user "test" defined without a password, as two other people pointed out.

The other usernames, not having a local account defined, are falling back to use the enable secret, which I'm guessing is "test".

Your "test" user isn't working because it DOES have a local profile, so it doesn't use the enable fallback method, and its local profile does not have a password listed, so it can't login.

Try removing the "enable" fallback method from the "aaa authentication login" line, but make sure you add a password to your local "test" user first.

User avatar
Pasu
New Member
Posts:
23
Joined:
Sun Apr 28, 2013 11:39 pm

Re: cisco switch 2960

Mon Apr 29, 2013 2:01 am

That worked perfectly.
Thank you so much to all of you.
Thank you bertschs for the explanation.
:thankyou:
"Lay a firm Foundation with the bricks that others throw at you" ~David Brinkley

User avatar
wirerat
Post Whore
Posts:
5331
Joined:
Tue Mar 31, 2009 4:15 pm
Certs:
More than none

Re: cisco switch 2960

Mon Apr 29, 2013 7:38 am

Code tags inserted.

OP, please use code tags in the future.
"See packet, be packet, you are packet. Ignore all else!" -The Networker
packetsdropped.wordpress.com

'

Return to Cisco Routing and Switching

Who is online

Users browsing this forum: Exabot [Bot], mlan, Otanx and 23 guests