IPv6 design, deployment, standards, and best practices.
kriskl03
New Member
Posts:
5
Joined:
Mon Dec 19, 2011 2:58 pm

IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 12:46 pm

Hello , I am trying to setup nat-pt so that an ipv6-only network can communicate with an ipv4-only network and vice-versa..

I have followed the cisco ipv6 configuration guide and the following link http://cciethebeginning.wordpress.com/2 ... ransition/

- Static NAT-PT, Dynamic NAT-PT and PAT overload were working

- however IPv4-mapped is not working and unfortunately for me it's what i have to implement on a network

Image


Routers' configuration with important commands;

Router0 config;
ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
ipv6 address 2001:A:B:C::4/64
ipv6 nat prefix 2001::/96 v4-mapped WHAT_to_IPv4
ipv6 enable
ipv6 nat
!
interface FastEthernet0/1
ip address 192.168.40.199 255.255.255.0

ipv6 nat
!
ipv6 nat v4v6 source 192.168.40.104 2001::C0A8:2868
ipv6 nat v6v4 source list list_to-ipv4 interface FastEthernet0/1 overload


ipv6 access-list list_to-ipv4
permit ipv6 2001:A:B:C::/64 any


ipv6 access-list WHAT_to_IPv4
permit ipv6 any 2001::/96
!

end



Router2 config;

ipv6 unicast-routing
!
interface FastEthernet0/0
no ip address
ipv6 address 2001:A:B:C::1/64
ipv6 enable
!
ipv6 route ::/0 2001:A:B:C::4
!
end



Router1 config;
interface FastEthernet0/0

ip address 192.168.40.200 255.255.255.0
!
end




Now, when i ping ''server'' from ''router2'', even static is not working. i.e "ping ipv6 2001::C0A8:2868" says unreachable.

ALso when testing v4mapped i.e "ping 2001::192.168.40.200", same result.

After lots of trial,testing,web research, i still have no clue what configuration is wrong.


note ; i have also attached the packet tracer simulation file.
Attachments
ccie blog_NAT-PT_IPv4 MAPPED.pkt.zip
(21.4 KiB) Downloaded 73 times

User avatar
jdsilva
Post Whore
Posts:
5347
Joined:
Mon Jan 17, 2005 11:01 pm
Certs:
CCNP

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 12:48 pm

NAT-PT is deprecated. Don't waste your time.

kriskl03
New Member
Posts:
5
Joined:
Mon Dec 19, 2011 2:58 pm

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 1:20 pm

thanks for replying, but then what technology can i use to connect the ipv6 and ipv4 networks together?
- dual-stack is not possible in my network
- and i believe tunneling is used when two ipv6 networks needs to be connected through an ipv4 network

User avatar
writeerase
Ultimate Member
Posts:
509
Joined:
Sat Apr 09, 2011 3:55 pm
Certs:
CCIE CCNP-S CCDA MCSE RHCT Sec+ A+

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 1:27 pm

LISP

kriskl03
New Member
Posts:
5
Joined:
Mon Dec 19, 2011 2:58 pm

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 1:38 pm

LISP? , possible on packet tracer?

User avatar
writeerase
Ultimate Member
Posts:
509
Joined:
Sat Apr 09, 2011 3:55 pm
Certs:
CCIE CCNP-S CCDA MCSE RHCT Sec+ A+

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 1:41 pm

seriously doubt it

Reggle
Post Whore
Posts:
1824
Joined:
Sun May 15, 2011 4:16 pm
Certs:
CCNA Security, CCNP, CCDP

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 3:31 pm

Nothing of this is possible on Packet Tracer.
http://reggle.wordpress.com

kriskl03
New Member
Posts:
5
Joined:
Mon Dec 19, 2011 2:58 pm

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Wed Feb 15, 2012 5:24 pm

thanks, but can somebody tell me if v4-mapped configuration works in packet tracer?

Reggle
Post Whore
Posts:
1824
Joined:
Sun May 15, 2011 4:16 pm
Certs:
CCNA Security, CCNP, CCDP

Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Thu Feb 16, 2012 3:15 pm

Reggle wrote:Nothing of this is possible on Packet Tracer.
http://reggle.wordpress.com

'

Return to IPv6

Who is online

Users browsing this forum: No registered users and 1 guest