All Juniper related discussions.
User avatar
Carlitos_30
Post Whore
Posts:
1222
Joined:
Mon Feb 08, 2010 9:30 am
Certs:
CCENT, CCNA,CCNP R&S

Please recommend tutorial to run Olive

Thu Nov 17, 2011 9:26 pm

Hello!

Next week I'm going to go to a Juniper course. I have very little experience with Junos and I'm trying to run Olive with no success. Do you have a good tutorial to install this? (I mean you followed that tutorial and it worked great).

I have tried to run Olive in Qemu and in VMware under Windows environment.

User avatar
timhalo
Senior Member
Posts:
413
Joined:
Fri Apr 29, 2011 8:26 pm
Certs:
CCNP, CCIP, JNCIS-ENT, M&M, PB&J, etc.

Re: Please recommend tutorial to run Olive

Sat Nov 19, 2011 2:44 am

I used this one Olive reloaded or how to emulate Juniper routers mostly. It talks about running olive on mac/win/nix.

Mine wouldn't work right until I enabled Virtualization (to enable KVM module) in the computer bios. (I'm on 'nix so don't know if matters on win).

User avatar
Carlitos_30
Post Whore
Posts:
1222
Joined:
Mon Feb 08, 2010 9:30 am
Certs:
CCENT, CCNA,CCNP R&S

Re: Please recommend tutorial to run Olive

Sat Nov 19, 2011 9:29 pm

Thanks for the link.

I use Windows so I used a different tutorial:

http://blogo.biz/?p=77

After a lot of hours, lots of tutorials, and at 23:26 PM I got the damned machine working.

Now I need to connect the two VM but It seems VMware doesn't support multicasting :evil: .

User avatar
Carlitos_30
Post Whore
Posts:
1222
Joined:
Mon Feb 08, 2010 9:30 am
Certs:
CCENT, CCNA,CCNP R&S

Re: Please recommend tutorial to run Olive

Sat Nov 19, 2011 9:31 pm

It was to good to be true.

It seems Junos loaded in the virtual machine but it doesn't recognize the Junos commands. I am now in some FreeBSD environment:


Amnesiac (ttyd0)

login: root

--- JUNOS 10.1R1.8 built 2010-02-12 17:15:05 UTC
root@% show config
show: Command not found.
root@% show
show: Command not found.
root@%
root@%
root@%
root@%
root@%
root@% ?
?: No match.
root@% dir
dir: Command not found.
root@% ls
.cshrc .login .profile
root@%


WTF?

UPDATE: Noob mistake. It's necessary to input "cli" to enter the JUNOS CLI.

killabee
Post Whore
Posts:
1458
Joined:
Sat Dec 19, 2009 11:52 pm
Certs:
CCNP, CCDA, JNCIA

Re: Please recommend tutorial to run Olive

Sat Nov 19, 2011 10:05 pm

Carlitos_30 wrote: Now I need to connect the two VM but It seems VMware doesn't support multicasting :evil: .


Have you tried setting up the VMs in a team and connecting them together with a LAN segment in the team? That's what I did a few years back with VMware Workstation.

User avatar
Carlitos_30
Post Whore
Posts:
1222
Joined:
Mon Feb 08, 2010 9:30 am
Certs:
CCENT, CCNA,CCNP R&S

Re: Please recommend tutorial to run Olive

Sat Nov 19, 2011 11:43 pm

Have you tried setting up the VMs in a team and connecting them together with a LAN segment in the team? That's what I did a few years back with VMware Workstation.



What do you mean with "in a team"? My research lead me to configuring WM with the "host only" option.

killabee
Post Whore
Posts:
1458
Joined:
Sat Dec 19, 2009 11:52 pm
Certs:
CCNP, CCDA, JNCIA

Re: Please recommend tutorial to run Olive

Sun Nov 20, 2011 1:12 am

On VMware Workstation 6, you can create a 'team,' which is basically a group of VMs:

Image

You can then create virtual LAN segments where they connect to:

Image

So you could have two (or more) Olives, each with multiple Ethernet interfaces, with one of those interfaces on each connected to a virtual LAN segment.

How were you going to use multicast for this?

User avatar
Carlitos_30
Post Whore
Posts:
1222
Joined:
Mon Feb 08, 2010 9:30 am
Certs:
CCENT, CCNA,CCNP R&S

Re: Please recommend tutorial to run Olive

Sun Nov 20, 2011 11:05 am

Thanks for the tip.

:thankyou:

How were you going to use multicast for this?


I went to adapt the info of this links to windows.

http://knol.google.com/k/configuring-basic-rip-using-a-juniper-olive-junos-via-cli#
http://knol.google.com/k/configuring-vmware-2-0-server-networking-on-a-linux-host#


Edit: Just for future reference, in WM Worlstation 7.x and 8.x ,the teams concept has been removed. Now the job is done under groups.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2006104#Groupings

Morphic
New Member
Posts:
21
Joined:
Wed May 05, 2010 3:27 am
Certs:
CCNA, VCP3&5 ,JNCIS-FWV, JNCIS-SEC CCNP

Re: Please recommend tutorial to run Olive

Sat Nov 26, 2011 6:07 am

You don't need to know anything about multicast for the jncia-junos, but I guess you're going beyond that now?

User avatar
Carlitos_30
Post Whore
Posts:
1222
Joined:
Mon Feb 08, 2010 9:30 am
Certs:
CCENT, CCNA,CCNP R&S

Re: Please recommend tutorial to run Olive

Sat Nov 26, 2011 8:28 am

OSPF and RIP use multicating and it enters in the exam(that was what I read). By the way, I installed JUNOS 10.1 and I was able to establish OSPF adjacencies.

'

Return to Juniper Networking

Who is online

Users browsing this forum: No registered users and 4 guests