IPv6 design, deployment, standards, and best practices.
quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Configuring IPV6 Basic

Sun Apr 29, 2012 10:37 am

I have added the ipv6 addres to routers of topology but there isn't connection between ajacents routers. I have attached a document with the followed steps in the configuration.

My objective is to pinging between adjacents router to after apply routing procotocol.


Code: Select all
GANDIA#sh ipv6 interface brief
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:1::C0A8:2



GANDIA#sh run
Building configuration...

Current configuration : 723 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GANDIA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
interface Serial0/0
 no ip address
 ipv6 address 2001:1111:2222:1::C0A8:2/64
 serial restart-delay 0
!
!
no ip http server
ip classless
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

--------------------------------------------------------------------------------------------------------------------

VALENCIA#sh ipv6 interface brief
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    3000::1
Serial0/1                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:1::C0A8:1



VALENCIA#sh run
Building configuration...

Current configuration : 776 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VALENCIA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
interface Serial0/0
 no ip address
 ipv6 address 3000::1/64
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/1
 no ip address
 ipv6 address 2001:1111:2222:1::C0A8:1/64
 serial restart-delay 0
 clock rate 64000
!
!
no ip http server
ip classless
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

-----------------------------------------------------------------------------------------------------------------------------

BARCELONA#sh ipv6 interface brief
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    3000::2
Serial0/1                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:2::C0A8:101


BARCELONA#sh run
Building configuration...

Current configuration : 761 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BARCELONA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
interface Serial0/0
 no ip address
 ipv6 address 3000::2/64
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 ipv6 address 2001:1111:2222:2::C0A8:101/64
 serial restart-delay 0
 clock rate 64000
!
no ip http server
ip classless
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

----------------------------------------------------------------------------------------------------------------------------------------
PRAT_LLOBREGAT#sh ipv6 interface brief
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:2::C0A8:102

RAT_LLOBREGAT#sh run
Building configuration...

Current configuration : 733 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PRAT_LLOBREGAT
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
interface Serial0/0
 no ip address
 ipv6 address 2001:1111:2222:2::C0A8:102/64
 serial restart-delay 0
!
!
no ip http server
ip classless

line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end







Thanks,
Attachments
Topology&ScreenConfigurationIPv6.jpg
Screen Routers
Topology&ScreenConfigurationIPv6.jpg (227.09 KiB) Viewed 1548 times

Captainserious
New Member
Posts:
25
Joined:
Wed Oct 12, 2011 6:04 am
Certs:
CCNA

Re: Configuring IPV6 Basic

Sun Apr 29, 2012 3:12 pm

Can't see anything outright wrong with this, have you made sure you've got the IP addresses configured on the correct interfaces? Can you post a show ipv6 int brief.

Rakurai
Member
Posts:
142
Joined:
Wed Nov 17, 2010 3:13 pm
Certs:
A+, N+, Sec+, CCENT

Re: Configuring IPV6 Basic

Sun Apr 29, 2012 3:40 pm

ipv6 unicast-routing is missing from the interfaces, i think..... haven't labbed IPv6 in a while.

Captainserious
New Member
Posts:
25
Joined:
Wed Oct 12, 2011 6:04 am
Certs:
CCNA

Re: Configuring IPV6 Basic

Sun Apr 29, 2012 3:41 pm

Rakurai wrote:ipv6 unicast-routing is missing from the interfaces, i think..... haven't labbed IPv6 in a while.


Not sure it would let you add IPv6 addresses if you didn't have it on... I could be wrong though!

User avatar
srg
Post Whore
Posts:
1712
Joined:
Thu Dec 30, 2010 2:05 pm
Certs:
CCIE SP, CCNP SP, CCNP, CCDA, CCNA DC/W, HP MASE

Re: Configuring IPV6 Basic

Sun Apr 29, 2012 3:44 pm

Rakurai wrote:ipv6 unicast-routing is missing from the interfaces, i think..... haven't labbed IPv6 in a while.

ipv6 unicast-routing is a global command. IPv6 is activated on the interface when you give it a global adress, or with "ipv6 enable" which will give it just the link-local.
som om sinnet hade svartnat för evigt.

Rakurai
Member
Posts:
142
Joined:
Wed Nov 17, 2010 3:13 pm
Certs:
A+, N+, Sec+, CCENT

Re: Configuring IPV6 Basic

Sun Apr 29, 2012 3:55 pm

srg wrote:
Rakurai wrote:ipv6 unicast-routing is missing from the interfaces, i think..... haven't labbed IPv6 in a while.

ipv6 unicast-routing is a global command. IPv6 is activated on the interface when you give it a global adress, or with "ipv6 enable" which will give it just the link-local.



Yes, it is global.... read my notes wrong.

quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Re: Configuring IPV6 Basic

Sun Apr 29, 2012 6:06 pm

Thanks everybody, I have added the global command ipv6 unicast-routing and the command ipv6 enable in the interface OK.

See the next changes

Code: Select all
VALENCIA(config)#ipv6 unicast-routing
[b]VALENCIA(config)#int serial 0/0[/b]
VALENCIA(config-if)#ipv6 address 3000::1/64
VALENCIA(config-if)#clock rate 64000
VALENCIA(config-if)#ipv6 enable
VALENCIA(config-if)#no sh
[b]VALENCIA(config)#int serial0/1[/b]
VALENCIA(config-if)#ipv6 address 2001:1111:2222:1::C0A8:1/64
VALENCIA(config-if)#clock rate 64000
VALENCIA(config-if)#ipv6 enable
VALENCIA(config-if)#no sh

GANDIA(config)#ipv6 unicast-routing
[b]GANDIA(config)#int serial 0/0[/b]
GANDIA(config-if)#ipv6 address 2001:1111:2222:1::C0A8:2/64
GANDIA(config-if)#no sh
GANDIA(config-if)#ipv6 enable


BARCELONA(config)#ipv6 unicast-routing
[b]BARCELONA(config)#int serial 0/0[/b]
BARCELONA(config-if)#ipv6 address  3000::2/64
BARCELONA(config-if)#ipv6 enable
BARCELONA(config-if)#no sh
[b]BARCELONA(config-if)#int serial 0/1[/b]
BARCELONA(config-if)#ipv6 address 2001:1111:2222:2::C0A8:101/64
BARCELONA(config-if)#ipv6 enable
BARCELONA(config-if)#clock rate 64000
BARCELONA(config-if)#no sh

PRAT_LLOBREGAT(config)#ipv6 unicast-routing
[b]PRAT_LLOBREGAT(config)#int serial 0/0[/b]
PRAT_LLOBREGAT(config-if)#ipv6 address 2001:1111:2222:2::C0A8:102/64
PRAT_LLOBREGAT(config-if)#ipv6 enable
PRAT_LLOBREGAT(config-if)#no sh


[b]VALENCIA#sh ipv6 interface brief[/b]
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    3000::1
Serial0/1                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:1::C0A8:1



[b]BARCELONA#sh ipv6 interface brief[/b]
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    3000::2
Serial0/1                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:2::C0A8:101

[b]PRAT_LLOBREGAT#sh ipv6 interface brief[/b]
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:2::C0A8:102


[b]GANDIA#sh ipv6 interface brief[/b]
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:1::C0A8:2

THE SHOW RUN COMMANDS
[b]VALENCIA#sh ru[/b]
Building configuration...

Current configuration : 768 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VALENCIA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
ip cef
[b]ipv6 unicast-routing[/b]
!
interface Serial0/0
 no ip address
 ipv6 address 3000::1/64
 ipv6 enable
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/1
 no ip address
 ipv6 address 2001:1111:2222:1::C0A8:1/64
 ipv6 enable
 serial restart-delay 0
 clock rate 64000
!
!
ip http server
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end


[b]BARCELONA#sh run[/b]
Building configuration...

Current configuration : 761 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BARCELONA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ipv6 unicast-routing
!
!
!
interface Serial0/0
 no ip address
 ipv6 address 3000::2/64
 ipv6 enable
 serial restart-delay 0
 no fair-queue
!
interface Serial0/1
 no ip address
 ipv6 address 2001:1111:2222:2::C0A8:101/64
 ipv6 enable
 serial restart-delay 0
 clock rate 64000
!
!
ip http server
ip classless
line con 0
line aux 0
line vty 0 4
!
!
end


[b]GANDIA#sh run[/b]
Building configuration...

Current configuration : 710 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GANDIA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2001:1111:2222:1::C0A8:2/64
 ipv6 enable
 serial restart-delay 0
 no fair-queue
!
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end


[b]PRAT_LLOBREGAT#sh run[/b]
Building configuration...
Current configuration : 720 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PRAT_LLOBREGAT
!
boot-start-marker
boot-end-marker

no aaa new-model
ip subnet-zero
ip cef
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2001:1111:2222:2::C0A8:102/64
 ipv6 enable
 serial restart-delay 0
 no fair-queue
!
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end



I have checked and all is OK. But is impossible to pinging between adjacents routers.

VALENCIA#ping 3000::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3000::2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


PRAT_LLOBREGAT#ping 2001:1111:2222:2::C0A8:101

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1111:2222:2::C0A8:101, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Probably will be a silly wrong but this is crazy.

User avatar
ristau5741
Post Whore
Posts:
10492
Joined:
Tue Aug 21, 2007 2:15 pm
Certs:
Instanity

Re: Configuring IPV6 Basic

Mon Apr 30, 2012 7:36 am

I thought there was a different command to ping in ipv6
maybe i"m thinking about something else.

ping ipv6 [ipv6-address]
Tips of the day:
- The human mind is the ultimate creation invention.
- I have so many customers, my customers have customers.
- Sausage time
- POP, stack, and store

quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Re: Configuring IPV6 Basic

Mon Apr 30, 2012 9:51 am

Sorry, I wrote bad, but with command ping ipv6 [ipv6 address] neither there are connection between adjacents devices.

GANDIA#ping ipv6 2001:1111:2222:1::C0A8:1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1111:2222:1::C0A8:1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Code: Select all
VALENCIA#sh ipv6 interface brief
Serial0/0                  [up/up]
    FE80::FFFF:FE10:45C5
    3000::1
Serial0/1                  [up/up]
    FE80::FFFF:FE10:45C5
    2001:1111:2222:1::C0A8:1
Serial0/2                  [administratively down/down]
    unassigned
Serial0/3                  [administratively down/down]
    unassigned


Please anybody would can to make this exercise? Is 10 minutes so will checked that is impossible to pinging.

Thanks,

User avatar
srg
Post Whore
Posts:
1712
Joined:
Thu Dec 30, 2010 2:05 pm
Certs:
CCIE SP, CCNP SP, CCNP, CCDA, CCNA DC/W, HP MASE

Re: Configuring IPV6 Basic

Mon Apr 30, 2012 1:54 pm

In the absence of an ethernet interface it seems as if all serial interfaces on all routers has come up with the same link-local address of FE80::FFFF:FE10:45C5, which means that on all links DAD would have yelled DUP and put one side in stalled mode.

Please check "show ipv6 int s0/0" on GANDIA and "show ipv6 int s0/1" on VALENCIA, one of the side should show "IPv6 is stalled, link-local address is FE80::FFFF:FE10:45C5 [DUP]"

If that is the case, change one of the sides manually and it will work.
som om sinnet hade svartnat för evigt.

quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Re: Configuring IPV6 Basic

Mon Apr 30, 2012 6:54 pm

Oh my good!! This was the problem!!

I have searching information but don't find the command to change the address link-local



Code: Select all
GANDIA>en
GANDIA#sh ipv6 int serial 0/0
Serial0/0 is up, line protocol is up
  IPv6 is stalled, link-local address is FE80::FFFF:FE10:45C5 [DUPLICATE]
  Global unicast address(es):
    2001:1111:2222:1::C0A8:2, subnet is 2001:1111:2222:1::/64 [TENTATIVE]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF10:45C5
    FF02::1:FFA8:2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.




BARCELONA#sh ipv6 interface serial 0/0
Serial0/0 is up, line protocol is up
  IPv6 is stalled, link-local address is FE80::FFFF:FE10:45C5 [DUPLICATE]
  Global unicast address(es):
    3000::2, subnet is 3000::/64 [TENTATIVE]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:2
    FF02::1:FF10:45C5
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
BARCELONA#


I have changed the link-local address and work OK!

GANDIA(config-if)#ipv6 address FE80::FFFF:FE10:45C6 link-local

Code: Select all
GANDIA#sh ipv6 interface serial 0/0
Serial0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::FFFF:FE10:45C6
  Global unicast address(es):
    2001:1111:2222:1::C0A8:2, subnet is 2001:1111:2222:1::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF10:45C6
    FF02::1:FFA8:2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
GANDIA#ping 2001:1111:2222:1::C0A8:1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1111:2222:1::C0A8:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/71/96 ms


Thanks for all! You are the best! I have been for days and nobody found the trouble.

User avatar
srg
Post Whore
Posts:
1712
Joined:
Thu Dec 30, 2010 2:05 pm
Certs:
CCIE SP, CCNP SP, CCNP, CCDA, CCNA DC/W, HP MASE

Re: Configuring IPV6 Basic

Tue May 01, 2012 12:51 am

Great :]. That is probably a PT bug, real routers shouldnt have come up with the same link-local everywhere.

Sent from my LT26i using Tapatalk 2
som om sinnet hade svartnat för evigt.

Davidr
Senior Member
Posts:
485
Joined:
Wed Aug 24, 2011 1:43 am
Certs:
CCNP

Re: Configuring IPV6 Basic

Tue May 01, 2012 3:44 am

ipv6 unicast-routing allows the router to route packets.
if it is not there, then the router acts an ipv6 host.

that was my understanding from reading(still) the ipv6 chapters.

User avatar
srg
Post Whore
Posts:
1712
Joined:
Thu Dec 30, 2010 2:05 pm
Certs:
CCIE SP, CCNP SP, CCNP, CCDA, CCNA DC/W, HP MASE

Re: Configuring IPV6 Basic

Tue May 01, 2012 4:07 am

Davidr wrote:ipv6 unicast-routing allows the router to route packets.
if it is not there, then the router acts an ipv6 host.

that was my understanding from reading(still) the ipv6 chapters.

yup that is correct.
som om sinnet hade svartnat för evigt.

'

Return to IPv6

Who is online

Users browsing this forum: No registered users and 4 guests