IPv6 design, deployment, standards, and best practices.
User avatar
dieselboy
Post Whore
Posts:
2745
Joined:
Tue Aug 05, 2008 6:36 am
Certs:
CCNP, CCNA Voice, SMB Select, Linux+

IPv6 dual-stack - CUCME odd issue

Mon Jun 25, 2012 12:33 am

So, last week I enable IPv6 in my home lab (back in England) for the purpose of accessing certain IPv6 only websites and for some learning experiences. I initially tried to use DHCPv6 but this would not work at all alongside DHCPv4. I did not remove the v4 scopes at all as this is a working lab (people in the home use it). Instead I use IPv6 auto configuration which allowed the machine to get an address and things began working. I could then access the IPv6 internet via a tunnel which was configured previously. Here's the, somewhat flaky config:

Code: Select all
int vl 70
 ipv6 address 2001:0:0:25E::1/64
 ipv6 enable
 ipv6 nd other-config-flag
 ipv6 dhcp server IPV6POOL

ipv6 dhcp pool IPV6POOL
 dns-server 2620:0:CCC::2
 dns-server 2620:0:CCD::2



All is working well. Then today I am told the phones have dropped off and are saying configuring IP. The phones are on the same broadcast domain as the PCs and both use the same DHCP v4 scope. An option 150 points the phones to the CUCME. I thought maybe the IPv6 address was being issued to the phone but did not contain a option 150 parameter. So instead of using IPv4 I'm assuming the phone was just rebooting. I tried adding this to the scope but it did not work:

Code: Select all
ipv6 dhcp pool IPV6POOL
 dns-server 2620:0:CCC::2
 dns-server 2620:0:CCD::2
 vendor-specific 150
  suboption 150 address 2001:0:0:25E::2
 ip address dhcp
 ipv6 dhcp server IPV6POOL


I couldnt find much online about the v6 options... The above is probably wrong. I tried "vendor-specific 1" with suboption 150 also but this too didn't get the phone to register.

To get the main phone working again I had to do this:
Code: Select all
ip dhcp pool DS-PHONE
 host 192.168.192.65 255.255.255.0
 client-identifier 0100.15f9.490c.ba
 default-router 192.168.192.254
 dns-server 208.67.220.220 8.8.8.8
 option 150 ip 192.168.192.253


So for now, the main phone works but the one upstairs in my room does not. Has anyone run into this kind of issue, or is my config above blindingly obviously wrong to someone?
Meanwhile, back in the city...

'
Return to IPv6

Who is online

Users browsing this forum: No registered users and 3 guests