All other Cisco networking related discussions.
fillthy
New Member
Posts:
11
Joined:
Mon Apr 30, 2012 9:18 am

Cisco 5510 AnyConnect VPN SpliTunneling

Mon Apr 30, 2012 9:20 am

Hi, in my testing phase for a new 5510. I've got a basic config. AnyConnect VPN is setup. Clients download and install package ok. But cannot ping anything on internal network once connected (192.168.105.0/24) Any suggestions would be appreciated.
Thanks

: Saved
:
ASA Version 8.2(5)
!
hostname ciscoasa
enable password xxxxxxxx encrypted
passwd xxxxxxxxx encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 72.38.x.x 255.255.255.240
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.105.3 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
ftp mode passive
access-list 101 extended permit icmp any any echo
access-list 101 extended permit icmp any any echo-reply
access-list 101 extended permit tcp any interface outside eq 3389
access-list no_nat extended permit ip 192.168.105.0 255.255.255.0 192.168.26.0 2
55.255.255.0
access-list Split-Tunnel standard permit 192.168.105.0 255.255.255.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
ip local pool AnyConnect-POOL 192.168.26.100-192.168.26.230 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 0 access-list no_nat
nat (inside) 101 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.105.10 3389 netmask 255.255.2
55.255
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 72.38.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.105.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable outside
anyconnect-essentials
svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
svc enable
tunnel-group-list enable
group-policy AnyConnect internal
group-policy AnyConnect attributes
vpn-tunnel-protocol svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split-Tunnel
webvpn
url-list none
svc ask enable
username AnyConnect1 password xxxxxxxxxxxxxxxxxx encrypted
username AnyConnect1 attributes
vpn-group-policy AnyConnect
tunnel-group AnyConnect-VPN type remote-access
tunnel-group AnyConnect-VPN general-attributes
address-pool AnyConnect-POOL
default-group-policy AnyConnect
tunnel-group AnyConnect-VPN webvpn-attributes
group-alias AnyConnect enable
group-url https://72.38.x.x/AnyConnect enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:3944fe2f2820734a09aec31bcf8151ba
: end

User avatar
dlots
Post Whore
Posts:
3512
Joined:
Mon Jun 15, 2009 9:48 am
Certs:
CC\NP\DP\IP\NP-Security\NA-Voice

Re: Cisco 5510 AnyConnect VPN SpliTunneling

Mon Apr 30, 2012 12:52 pm

are you pinging by IP address or by DNS name? cause you don't seem to have any DNS servers there
Here is my basic config for making an any connect split tunnel VPN with LDAP auth (hope this helps)
### = The name of the VPN group


ldap attribute-map CISCOMAP
map-value memberOf "CN=vpn-###,OU="OUT-GROUP",OU="MORE OU INFO",OU="MORE OU-INFO",DC="DC INFO",DC="DC INFO",DC=DC-INFO" ###

dynamic-access-policy-record ###
description "###"

group-policy ### internal
group-policy ### attributes
wins-server none
dns-server value 10.254.10.82 10.254.20.82 (insert whatever your DNS servers are... just be sure you give them access)
vpn-tunnel-protocol ikev1 ssl-client
split-tunnel-network-list value ### (this is an ACL you make saying where you want it to have access to)
default-domain value "YOUR-DOMAIN-NAME"
address-pools value ###

tunnel-group ### type remote-access
tunnel-group ### general-attributes
authentication-server-group LDAP
default-group-policy ###
Freedom to all the people. Brave, true and strong.
Freedom to all the people. Unless I think you're wrong

dhimes.com

fillthy
New Member
Posts:
11
Joined:
Mon Apr 30, 2012 9:18 am

Re: Cisco 5510 AnyConnect VPN SpliTunneling

Mon Apr 30, 2012 1:40 pm

Thanks for the reply..I'm connecting via IP address only for now. I'm sure it's a spit tunnel or nat exempt issue but just cannot figure it out.
Cheers
Phil

fillthy
New Member
Posts:
11
Joined:
Mon Apr 30, 2012 9:18 am

Re: Cisco 5510 AnyConnect VPN SpliTunneling

Tue May 01, 2012 2:21 pm

This has been resolved..It was a routing issue.

'

Return to Cisco General

Who is online

Users browsing this forum: Exabot [Bot] and 17 guests