ASA/PIX, IDS, IPS, VPN, Cisco Secure ACS, AAA, ISE.
fillthy
New Member
Posts:
11
Joined:
Mon Apr 30, 2012 9:18 am

5510 AnyConnect vpn client access second interface

Mon May 07, 2012 12:07 pm

I have an ASA 5510 with two inside interfaces: "inside" 192.168.105.x and "inside110" 192.168.110.x. I'm using the AnyConnect VPN client with split tunneling to get access to the 192.168.105.x subnet from a VPN client. I also enabled the same-security-traffic command so that I can communicate between the two inside interfaces. I now want my VPN clients to be able to access this "inside110" network also..Any ideas?

: Saved
: Written by enable_15 at 17:13:48.619 EST Fri May 4 2012
!
ASA Version 8.2(5)
!
hostname ditcisco
enable password myXecB/3z3.0XvkN encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 72.x.x.x 255.255.255.240
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.105.3 255.255.255.0
!
interface Ethernet0/2
nameif inside110
security-level 100
ip address 192.168.110.3 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
ftp mode passive
clock timezone EST -5
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 192.168.105.50
name-server 8.8.8.8
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list 101 extended permit icmp any any echo
access-list 101 extended permit icmp any any echo-reply
access-list 101 extended permit tcp any interface outside eq 3389
access-list no_nat extended permit ip 192.168.105.0 255.255.255.0 192.168.26.0 255.255.255.0
access-list no_nat extended permit ip 192.168.105.0 255.255.255.0 192.168.27.0 255.255.255.0
access-list no_nat extended permit ip 192.168.105.0 255.255.255.0 192.168.110.0 255.255.255.0
access-list no_nat extended permit ip 192.168.105.0 255.255.255.0 10.1.0.0 255.255.0.0
access-list no_nat extended permit ip 10.1.0.0 255.255.0.0 192.168.105.0 255.255.255.0
access-list Split-Tunnel standard permit 192.168.105.0 255.255.255.0
access-list Split-Tunnel standard permit 173.241.x.x 255.255.255.0
access-list vpnphone_splitTunnelAcl standard permit 192.168.105.0 255.255.255.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu inside110 1500
mtu management 1500
ip local pool AnyConnect-POOL 192.168.26.100-192.168.26.230 mask 255.255.255.0
ip local pool phonevpnpool 192.168.27.100-192.168.27.200 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (outside) 101 192.168.26.0 255.255.255.0
nat (inside) 0 access-list no_nat
nat (inside) 101 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.105.10 3389 netmask 255.255.255.255
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 72.38.x.x 1
route inside 10.1.0.0 255.255.0.0 192.168.110.9 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.105.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable outside
anyconnect-essentials
svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
svc profiles AnyConnectProfile disk0:/AnyConnectProfile.xml
svc enable
tunnel-group-list enable
group-policy vpnphone internal
group-policy vpnphone attributes
dns-server value 192.168.105.50
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnphone_splitTunnelAcl
default-domain none
group-policy AnyConnect internal
group-policy AnyConnect attributes
dns-server value 192.168.105.50
vpn-tunnel-protocol svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split-Tunnel
default-domain none
webvpn
url-list none
svc modules value vpngina
svc profiles value AnyConnectProfile
svc ask enable
username phone1 password xxxxxx encrypted privilege 0
username phone1 attributes
vpn-group-policy vpnphone
username AnyConnect1 password xxxxxx encrypted
username AnyConnect1 attributes
vpn-group-policy AnyConnect
tunnel-group AnyConnect type remote-access
tunnel-group AnyConnect general-attributes
address-pool AnyConnect-POOL
default-group-policy AnyConnect
tunnel-group AnyConnect webvpn-attributes
group-alias AnyConnect enable
group-url https://my.domain.com/ enable
tunnel-group vpnphone type remote-access
tunnel-group vpnphone general-attributes
address-pool phonevpnpool
default-group-policy vpnphone
tunnel-group vpnphone ipsec-attributes
pre-shared-key xxxxxx
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:7d40cedf04187a3c36f75c6157a74f10
: end

'
Return to Cisco Security

Who is online

Users browsing this forum: No registered users and 15 guests