CCENT, CCNA, CCNP, CCDA, CCDP, CCDE, CCIE, CCSP, CCVP, CCIP.
quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

CCNP ROUTE BGP

Wed Jun 27, 2012 7:13 am

Good afternoon,

I have to configured the BGP routing ok. After to check the routing tables i have to applied route-maps and perfix-list to change the local-preference.

Cust1_NY(config-router)#ip prefix-list C4 seq 5 permit 10.2.1.0/24
Cust1_NY(config)#ip prefix-list C5 seq 5 permit 10.2.2.0/24
Cust1_NY(config)#route-map HACIA_C4_C5
Cust1_NY(config-route-map)#match ip address prefix-list C4 C5
Cust1_NY(config-route-map)#set local-preference 300
Cust1_NY(config-route-map)#route-map HACIA_C4_C5
Cust1_NY(config-route-map)#set local-preference 250
Cust1_NY(config)#router bgp 65001
Cust1_NY(config-router)#neighbor 192.168.2.1 route-map HACIA_C4_C5 in




Cust1_SF(config-router)#ip prefix-list C2 seq 5 permit 10.1.1.0/24
Cust1_SF(config)#ip prefix-list C3 seq 5 permit 10.1.2.0/24
Cust1_SF(config)#route-map ENRUTAR_HACIA_C2_C3
Cust1_SF(config-route-map)#match ip address prefix-list C2 C3
Cust1_SF(config-route-map)#set local-preference 300
Cust1_SF(config-route-map)#route-map ENRUTAR_HACIA_C2_C3
Cust1_SF(config-route-map)#set local-preference 200
Cust1_SF(config-router)#neighbor 192.168.1.1 route-map ENRUTAR_HACIA_C2_C3 in


After to apply the changes i will reset the bgp routers

clear ip bgp <neighbor-ip>

The problem is that after to apply the reset the STATE of neighbors between Cust1_SF and Provider_SF


Code: Select all
Cust1_SF#show ip bgp neighbors
BGP neighbor is 192.168.1.1,  remote AS 65000, external link
  BGP version 4, remote router ID 0.0.0.0
  [b]BGP state = Active[/b]
  Last read 00:26:15, last write 00:26:15, hold time is 180, keepalive interval is 60 seconds
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  0          0
    Notifications:          0          0
    Updates:                0          0
    Keepalives:             0          0
    Route Refresh:          0          0
    Total:                  0          0
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 54, neighbor version 0/0
 Output queue size : 0
  Index 2, Offset 0, Mask 0x4
  2 update-group member
  Inbound path policy configured
  Route map for incoming advertisements is ENRUTAR_HACIA_C2_C3
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0

  Connections established 0; dropped 0
  Last reset never
  No active TCP connection

BGP neighbor is 192.168.3.1,  remote AS 65001, internal link
  BGP version 4, remote router ID 192.168.3.1
  BGP state = Established, up for 00:34:41
  Last read 00:00:41, last write 00:00:41, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  4          4
    Notifications:          0          0
    Updates:                5         17
    Keepalives:           143        143
    Route Refresh:          0          0
    Total:                152        164
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 54, neighbor version 54/0
 Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
  NEXT_HOP is always this router
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               3          5 (Consumes 260 bytes)
    Prefixes Total:                 3          5
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          4
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              4        n/a
    Total:                                4          0
  Number of NLRIs in the update sent: max 3, min 1

  Connections established 4; dropped 3
  Last reset 00:34:43, due to User reset
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 192.168.3.2, Local port: 57979
Foreign host: 192.168.3.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x7C46AC):
Timer          Starts    Wakeups            Next
Retrans            38          0             0x0
TimeWait            0          0             0x0
AckHold            37         35             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss:  259962811  snduna:  259963625  sndnxt:  259963625     sndwnd:  15571
irs:   27944054  rcvnxt:   27944931  rcvwnd:      15508  delrcvwnd:    876

SRTT: 298 ms, RTTO: 314 ms, RTV: 16 ms, KRTT: 0 ms
minRTT: 20 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: active open, nagle
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 39 (out of order: 0), with data: 37, total data bytes: 876
Sent: 75 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 38, total data bytes: 813




[b]Provider_SF#show ip bgp neighbors[/b]
BGP neighbor is 172.16.0.2,  remote AS 65000, internal link
  BGP version 4, remote router ID 192.168.2.1
  BGP state = Established, up for 00:23:51
  Last read 00:00:51, last write 00:00:51, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  4          4
    Notifications:          0          0
    Updates:                6         23
    Keepalives:           135        135
    Route Refresh:          0          0
    Total:                145        162
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 70, neighbor version 70/0
 Output queue size : 0
  Index 2, Offset 0, Mask 0x4
  2 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               3          8 (Consumes 416 bytes)
    Prefixes Total:                 3          8
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          7
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              7        n/a
    Total:                                7          0
  Number of NLRIs in the update sent: max 3, min 1

  Connections established 4; dropped 3
  Last reset 00:24:00, due to User reset
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 172.16.0.1, Local port: 48261
Foreign host: 172.16.0.2, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x742C80):
Timer          Starts    Wakeups            Next
Retrans            28          0             0x0
TimeWait            0          0             0x0
AckHold            27         11             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 3863243704  snduna: 3863244327  sndnxt: 3863244327     sndwnd:  15762
irs:  741909849  rcvnxt:  741910605  rcvwnd:      15629  delrcvwnd:    755

SRTT: 293 ms, RTTO: 352 ms, RTV: 59 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: active open, nagle
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 51 (out of order: 0), with data: 27, total data bytes: 755
Sent: 41 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 28, total data bytes: 622

BGP neighbor is 192.168.1.2,  remote AS 65001, external link
  BGP version 4, remote router ID 0.0.0.0
[b]  BGP state = Idle[/b]
  Last read 00:00:00, last write 00:00:00, hold time is 180, keepalive interval is 60 seconds
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  0          0
    Notifications:          0          0
    Updates:                0          0
    Keepalives:             0          0
    Route Refresh:          0          0
    Total:                  0          0
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 70, neighbor version 0/0
 Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0

  Connections established 0; dropped 0
  Last reset never
  External BGP neighbor not directly connected.
  No active TCP connection



Please i need help. I don't can to change the STATE.

Thanks,
Attachments
BGP_topology.jpg
BGP_topology.jpg (85.45 KiB) Viewed 516 times

quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Re: CCNP ROUTE BGP

Wed Jun 27, 2012 7:32 am

Furthermore checked the correct configuration AS in BGP



Code: Select all
Provider_SF#  sh run
Building configuration...

Current configuration : 1486 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Provider_SF
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Serial0/0
 ip address 172.168.1.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/1
 ip address 172.16.0.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 10.1.2.1 255.255.255.0
 duplex auto
 speed auto
!

router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 network 10.1.1.0 mask 255.255.255.0
 network 10.1.2.0 mask 255.255.255.0
 network 172.16.0.0 mask 255.255.255.252
 network 192.168.1.0 mask 255.255.255.252
 neighbor 172.16.0.2 remote-as 65000
 neighbor 192.168.1.2 remote-as 65001
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!

!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end


Cust1_SF#sh run
Building configuration...

Current configuration : 1599 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust1_SF
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface FastEthernet0/0
 ip address 192.168.3.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.252
 serial restart-delay 0
!

interface FastEthernet2/0
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 65001
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.0 mask 255.255.255.252
 network 192.168.3.0 mask 255.255.255.252
 network 192.168.10.0
 neighbor 192.168.1.1 remote-as 65000
 neighbor 192.168.1.1 route-map ENRUTAR_HACIA_C2_C3 in
 neighbor 192.168.3.1 remote-as 65001
 neighbor 192.168.3.1 next-hop-self
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
ip prefix-list C2 seq 5 permit 10.1.1.0/24
!
ip prefix-list C3 seq 5 permit 10.1.2.0/24
!
route-map ENRUTAR_HACIA_C2_C3 permit 10
 match ip address prefix-list C2 C3
 set local-preference 200
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end


Cust1_SF#show tcp brief all
TCB       Local Address           Foreign Address        (state)
64D37584  192.168.1.2.57409       192.168.1.1.179        SYNSENT
63FED958  192.168.3.2.57979       192.168.3.1.179        ESTAB
64D3C8B4  *.179                   192.168.3.1.*          LISTEN
64D3A050  *.179                   192.168.1.1.*          LISTEN

Provider_SF# show tcp brief all
TCB       Local Address           Foreign Address        (state)
64AC7B7C  172.16.0.1.48261        172.16.0.2.179         ESTAB
64D41FBC  *.179                   192.168.1.2.*          LISTEN
64D3F758  *.179                   172.16.0.2.*           LISTEN


User avatar
kannies
Post Whore
Posts:
1211
Joined:
Thu Jan 10, 2008 7:43 am

Re: CCNP ROUTE BGP

Wed Jun 27, 2012 7:50 am

After looking at your config, it seems that on Provider_SF you do not have an interface configured in the 192.168.1.0/30 subnet.
Check the ip addressing of your point to point link and ensure you can ping across it.

Then post the output.

edit , this doesn't look right...

Code: Select all
interface Serial0/0
ip address 172.168.1.1 255.255.255.252
serial restart-delay 0
clock rate 64000

prtech
Junior Member
Posts:
81
Joined:
Mon Mar 05, 2012 8:41 am
Certs:
CCNP, JNCIA-JUNOS, Security+

Re: CCNP ROUTE BGP

Wed Jun 27, 2012 8:12 am

This is what you configured:

Cust1_SF(config)#route-map ENRUTAR_HACIA_C2_C3
Cust1_SF(config-route-map)#match ip address prefix-list C2 C3
Cust1_SF(config-route-map)#set local-preference 300
Cust1_SF(config-route-map)#route-map ENRUTAR_HACIA_C2_C3
Cust1_SF(config-route-map)#set local-preference 200

But the configuration shows this:

route-map ENRUTAR_HACIA_C2_C3 permit 10
match ip address prefix-list C2 C3
set local-preference 200

That's because you didn't specify a sequence for your second configuration of the route map. When you did this:

Cust1_SF(config-route-map)#route-map ENRUTAR_HACIA_C2_C3
Cust1_SF(config-route-map)#set local-preference 200

You edited sequence 10 and that's why your local preference for prefix-list c2 and c3 is 200 instead of the 300 you configured. Doing this also blocks everything but the prefixes specified on c2 and c3.

Your config should look like this:

Cust1_SF(config-route-map)#route-map ENRUTAR_HACIA_C2_C3 permit 20
Cust1_SF(config-route-map)#set local-preference 200

quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Re: CCNP ROUTE BGP

Fri Jun 29, 2012 10:20 am

Thanks,

I have modiffied to permit 10 and permit 20. All perfect!!

If anybody need my resolution that tell me anything.

Best regards experts!

'

Return to Cisco Certifications

Who is online

Users browsing this forum: Recundis and 10 guests